Search found 1 match

Go to advanced search

by Zerfall
9 months
Forum: Announcements
Topic: Median XL 1.2 Released
Replies: 85
Views: 41775

Median XL 1.2 Released

Does the launcher not work with 1.2? It wants to install 1.1.3 over it and says version unknown when I manually install 1.2.

Go to advanced search