Need some help. Completely lost on installation.

Discuss Median XL!
10sorat01
Skeleton
2 | 0
So I recently got back into Diablo 2. No install disc, but fortunately I had an old backup on an external drive. Things worked fine for both Classic and Ancestral Recall. (Had to downgrade to patch 1.10 for that.)

I had no problem running an older version of Median from several years ago. So I decided to try the latest version. I updated to patch 1.14, backed down to 1.13, and d/l'd the current version of Median.

Now I get a crash every time I try to load it. I tried using the mod manager, but no matter what I do, it just loads classic 1.13. To add further frustration, neither Classic nor AR will load full screen anymore. It was working fine until I attempted to update Median.

If it helps, I'm running Win 10, and tried running both the classic and the Median mod in XP pack 3 AND Windows 7 compatibility. No dice. Any advice on how to:

A) Get MedianXL to run properly.
B) Get fullscreen mode running again.

Any help would be appriciated.
User avatar
suchbalance
Amazon Warrior
1675 | 394
Common Posting Badge
Posted over 1.000 messages
Great Popularity Badge
Has a thread with over 50.000 views
Great Love Badge
Earned over 100 cookies
Great Guide Badge
Created 3 complete character guides
Common Skill Badge
Experienced Player
Great Contribution Badge
Is an active forum collaborator / developer
Great Mind Badge
A Median XL guru... a true book of knowledge
It's really simple. Fresh install of D2 outside of program files. Use our launcher: http://get.median-xl.com/launcher . Make sure your AV isn't fucking with the mod files.
10sorat01
Skeleton
2 | 0
Thanks for the timely reply. I was afraid it might come down to a fresh install. I'll have to find a new copy. Ah well.
User avatar
Quirinus
Amazon Warrior
1682 | 159
Common Posting Badge
Posted over 1.000 messages
Common Popularity Badge
Has a thread with over 10.000 views
Great Love Badge
Earned over 100 cookies
Common Supporter Badge
Donated 1 time
Great Contribution Badge
Is an active forum collaborator / developer
You can always try using the Launcher without a fresh install. It might still work.
"but if it's simple it's not that hard" - Quirinus 2017
"small things like this are not a big deal" - Quirinus 2017
Ruler2112
Destroyer
6 | -2
I play on Linux through WINE/Play on Linux. All I did to install Median was to copy the D2Patch.mpq file into the Diablo II directory and run the original EXE. Everything just worked. If I add the DLLs that come with it, I get an unable to retrieve process error and the game won't start. I haven't played on windoze in 10+ years, so don't know if this will work or not, but might be worth a shot. Just copy the directory from your external HDD to a new folder on your PC, dump the d2patch file into it, run, and cross your fingers. :)

Never heard of Ancestral Recall before - may have to check that one out! (Though if it only works on 1.10, I'm probably out of luck; if I'm not mistaken, my installer disk came with 1.13.)
User avatar
Quirinus
Amazon Warrior
1682 | 159
Common Posting Badge
Posted over 1.000 messages
Common Popularity Badge
Has a thread with over 10.000 views
Great Love Badge
Earned over 100 cookies
Common Supporter Badge
Donated 1 time
Great Contribution Badge
Is an active forum collaborator / developer
You actually need the dlls to play the game, otherwise it will crash at some point, and features will be missing from the mod.

Unable to retrieve process on windows means that you need to run the game as admin. Don't know how to solve that on Linux/Wine, but I know some people solved it before.
"but if it's simple it's not that hard" - Quirinus 2017
"small things like this are not a big deal" - Quirinus 2017
Ruler2112
Destroyer
6 | -2
Nevermind my input then...