Problems with Median ? Read here first.

Discuss Median XL!
User avatar
RequiemLux
Son of Lucion
737 | 95
Common Popularity Badge
Has a thread with over 10.000 views
Common Love Badge
Earned over 20 cookies

Here's a list of useful tips if you keep getting errors while playing or trying to play Median:



Overall tips:


>If you want to play Multiplayer make sure to read this first: How to play on The Sin War.
>If you've downloaded a digital copy of Diablo II from Blizzard's site you got the 1.14 patch, manual downgrading to version 1.13c will no longer be possible, you'll have to use the MXL Launcher to play.
>The use of the MXL Launcher is by no means mandatory to play MedianXL but is highly recommended, especially if you end up getting errors while trying to play the mod without it.
>It's better to not install neither Diablo II nor the MXL Launcher in the "Program Files" folder.
>First of all consider to reinstall everything (files might be damaged) and re-download the mod (the archive might be corrupted or outdated). This usually solves 90% of the problems after a system reboot.
>Make sure all the .dll files are in Diablo II folder and not blocked by any Windows application and/or by your antivirus (might avert error "2239" and "c0000005").
>Run the Diablo II.exe as an Administrator, make sure the option is checked in Properties -> Compatibility -> Privilege Level (might avert error "2239" and "c0000005" and "Failed to retrieve process").
>If you're still getting problems run it also in WinXP SP3 compatibility mode, probably Win7 compatibility mode if you're using Win10 (might avert error "c0000005").
>If you're still getting problems add Diablo II to Windows DEP as an exception (might avert error "c0000005"):
► D2 as DEP exeption

>Look for any MXL issue with this utilities: Technical Support Resources
>If you're still getting problems make sure you're running windowed mode: 'right click' D2LoD shortcut -> Properties -> 'Shortcut tab' -> in the 'Target:' path add " -w" (without the quotes).
>If you're still getting problems make sure you're not running the game with the " -skiptobnet" command set in your shortcut target path.
>If you're still getting problems and/or very low fps try disabling sounds: 'right click' D2LoD shortcut -> Properties -> 'Shortcut tab' -> in the 'Target:' path add " -ns" (without the quotes)
Beware:
  • Do not use " -ns" with windowed mode on GLIDE-Wrapper.
  • Do not use " -ns" if you're game crash during a loading screen.
>If you're still getting errors try to disable DEP completely in your OS: Run the Command Prompt (CMD) as an Administrator -> type: bcdedit.exe /set {current} nx AlwaysOff -> Restart PC. (You can always turn it back on with this command: bcdedit.exe /set {current} nx AlwaysOn).
>Everything works except Multiplayer? Even after following the instruction here: How to play on The Sin War and trying everything written before? Try this:
► Registry edit

>Still getting errors? post your debuglog (appears in your Diablo II folder) here: MXL 1.3 Bugs&Feedback using the spoiler brackets to avoid flooding the thread with a wall of text.
>Keep in mind that D2MultiRes is not compatible anymore, you have to play with the game's native resolutions (max. 800x600).

Using the "MXL Launcher"(now PlugY compatible since version 0.3.1):


>Make sure to not have installed the MXL Launcher in the "Program Files" folder.
>Uninstall any previous median version or launcher's, delete patch_d2.mpq in your Diablo II folder (might avert error "2239"). Then get the last version of the MXL Launcher: MXL Launcher Setup (as of now is version 0.3.1) ---> Install and update.
>If you want to use PlugY with the MXL Launcher make sure you're using the PlugY version integrated in the launcher and not a separated or previously installed one.
>If the MXL Launcher keep crashing upon starting up, go into the Median XL folder and delete the file :"settings.json", then try starting the launcher once again.
>If any crash related to the use of the launcher occurs, it means that:
  • you didn't install the latest version of the MXL Launcher and are using the old one (MXL_Setup_v0.3.0).
  • you didn't delete patch_d2.mpq.
  • you didn't remove a previously installed version of PlugY.
>If you get the "Version Unknown" error try to run the D2VidTst, it may helps.
>If you still getting problems with the MXL Launcher post here about it: MXL Launcher then follow the instruction here: How to Join , run Diablo II as an Administrator and don't run the game trough the MXL Launcher.

Using "D2SE" with "PlugY"(both not recommended):


>They won't work if you're using the Diablo II web installer from Blizzard because of the released 1.14 that destroyed compatibility, also D2SE and PlugY don't work under 1.14 even if you downgrade Diablo II via MXL Launcher to 1.13c. So make sure it's not your case.
>If you use D2SE, download this: https://get.median-xl.com/d2se.zip
>If you want to use PlugY with D2SE, and avert a potential "c0000005" error, follow this guide: MXL20127, PlugY and D2SE installation and/or this video "MXL2017 - How to Install w/ D2SE and PlugY".
>Make sure PlugY.ini has this set in its .ini file: DllToLoad=MXL.dll (might avert error "2239").
>If you still get error with PlugY (fe: when you save) make sure that in the PlugY.ini file "ActiveMultiPageStash" is disabled (with a 0), like this: ActiveMultiPageStash=0 , this will disable the additional pages in the stash.
>If you can't play multiplayer even after following the instructions here: How to play on The Sin War , make sure that in your PlugY.ini file DisableBattleNet=1 is set to a 0 like this: DisableBattleNet=0
Edited by RequiemLux 1 day.
Alav44
Cultist
20 | 0
Common Supporter Badge
Donated 1 time
how do i avert my .dll files from windows and antivirus, i am getting the 2239 error once i boot up, and im not sure what privilege level is under my settings... i have everything installed correctly as ive installed four times already :(
User avatar
thanmadw
Stygian Watcher
43 | 0
Hello,
I successfully play game with D2SE and PlugY 10.00 in Single Player
But i can join in MultiPlayer (play online on 'The Sin War'), when i click on that button then nothing happen
Help me pls
User avatar
thanmadw
Stygian Watcher
43 | 0
thanmadw wrote:Hello,
I successfully play game with D2SE and PlugY 10.00 in Single Player
But i can join in MultiPlayer (play online on 'The Sin War'), when i click on that button then nothing happen
Help me pls


Thank to "Kyonai"
Fixed by: Your PlugY.ini file likely has DisableBattleNet=1 set. Change the 1 to a 0 and see if that fixes it.
jimbojen
Skeleton
2 | 0
Whenever I try to load the launcher after it is installed it brings up an error "the procedure entry point SHGetPropertyStoreForWindow could not be located in the dynamic link library SHELL32.dll. I have it installed in diabloii/medianXL like it should be, so not sure what the fix is for this....
User avatar
Rishab
Neon Fiend
2010 | 148
Common Posting Badge
Posted over 1.000 messages
Common Popularity Badge
Has a thread with over 10.000 views
Great Love Badge
Earned over 100 cookies
Common Contribution Badge
Has collaborated to our forums, realms or mod
Alav44 wrote:how do i avert my .dll files from windows and antivirus, i am getting the 2239 error once i boot up, and im not sure what privilege level is under my settings... i have everything installed correctly as ive installed four times already :(

try running the game in admin mode and compatibility of winxp sp3
New Bestiary(WIP)| Useful BBcodes| Extended Gamelist | Community Project: Median Wiki | ingame Questlog
Be the change you want to see in this community.
- Gandhi
User avatar
Quirinus
Amazon Warrior
1697 | 162
Common Posting Badge
Posted over 1.000 messages
Common Popularity Badge
Has a thread with over 10.000 views
Great Love Badge
Earned over 100 cookies
Common Supporter Badge
Donated 1 time
Great Contribution Badge
Is an active forum collaborator / developer
jimbojen wrote:Whenever I try to load the launcher after it is installed it brings up an error "the procedure entry point SHGetPropertyStoreForWindow could not be located in the dynamic link library SHELL32.dll. I have it installed in diabloii/medianXL like it should be, so not sure what the fix is for this....


Are you using windows?
"but if it's simple it's not that hard" - Quirinus 2017
"small things like this are not a big deal" - Quirinus 2017
Less][gr0ssman
Stone Warrior
33 | 0
I got huge spikes/freezes when i play on servers, not even in crowded areas, just randomly in game. In SP it goes much smoother but still a bit laggy. In previous XVI version it was ok.
Windows XP SP3, freshly installed, reinstalled D2 and plugy, good internet connection, tried -ns and D3D/Glide, run as administrator... Any ideas? Mb new game core is too laggy for my crap PC, can it be so?
Edit: now +to my lags i have this error 2 times in a same place (near entrance of lower curast act3 hatred)
► Show Spoiler
Less][gr0ssman
Stone Warrior
33 | 0
Thanks for help
Joey_Diamond
Vampiress
39 | 2
So i have to use D2se if i want to use PlugY. I use D2se version 2.22 or something but it already have PlugY 9.0 in it. Can you give me direction on how to upgrade it to PlugY 10.00? Like, just paste the new version on top of the older one or edit D2se to point it to the new version? Any help will be greatly appreciate. :beg: