Season 14

Game news and forum updates
Lorgard
Destroyer
7 | 0
Hi,

When i use the launcher, i can juste "restart" it, and can't launch the game
User avatar
Quirinus
Harpylisk
1436 | 125
Common Posting Badge
Posted over 1.000 messages
Common Popularity Badge
Has a thread with over 10.000 views
Great Love Badge
Earned over 100 cookies
Common Supporter Badge
Donated 1 time
Great Contribution Badge
Is an active forum collaborator / developer
Lorgard wrote:Hi,

When i use the launcher, i can juste "restart" it, and can't launch the game


did you download the newest launcher, and ran it as admin?
"but if it's simple it's not that hard" - Quirinus 2017
"small things like this are not a big deal" - Quirinus 2017
chuk15
Jungle Hunter
29 | 0
launcher crashes each time i try to press "play"
Lorgard
Destroyer
7 | 0
Hi, yes,

i've ran the older version of median yesterday, following the "how to join us" guide, but not using the launcher.

Today i've DL the lastest launcher and the patch, installed the launcher in the D2 folder, run it then copy/past the patch.

When i lauch the game, it return me an error, and when i lauch the launcher, it say "unknow version" and "restart"
Lorgard
Destroyer
7 | 0
Lorgard wrote:Hi, yes,

i've ran the older version of median yesterday, following the "how to join us" guide, but not using the launcher.

Today i've DL the lastest launcher and the patch, installed the launcher in the D2 folder, run it then copy/past the patch.

When i lauch the game, it return me an error, and when i lauch the launcher, it say "unknow version" and "restart"


Launcher v 0.2.7.0
xstormfirex
Djinn
505 | 6
The session 14 will be played through the downloaded file or should you download something else?

Demoniacs!!!!
User avatar
Quirinus
Harpylisk
1436 | 125
Common Posting Badge
Posted over 1.000 messages
Common Popularity Badge
Has a thread with over 10.000 views
Great Love Badge
Earned over 100 cookies
Common Supporter Badge
Donated 1 time
Great Contribution Badge
Is an active forum collaborator / developer
chuk15 wrote:launcher crashes each time i try to press "play"


You probably didn't update the launcher, but updated the game.

You can wait like 30 min for the new version of the launcher that will solve this,
or delete patch_d2.mpq from the D2 folder, update the launcher and run the launcher again.

Lorgard wrote:
Lorgard wrote:Hi, yes,
i've ran the older version of median yesterday, following the "how to join us" guide, but not using the launcher.
Today i've DL the lastest launcher and the patch, installed the launcher in the D2 folder, run it then copy/past the patch.
When i lauch the game, it return me an error, and when i lauch the launcher, it say "unknow version" and "restart"

Launcher v 0.2.7.0


You don't need to do both.
Anyways, just run the launcher again and it might work, otherwise see my response above.
"but if it's simple it's not that hard" - Quirinus 2017
"small things like this are not a big deal" - Quirinus 2017
User avatar
Quirinus
Harpylisk
1436 | 125
Common Posting Badge
Posted over 1.000 messages
Common Popularity Badge
Has a thread with over 10.000 views
Great Love Badge
Earned over 100 cookies
Common Supporter Badge
Donated 1 time
Great Contribution Badge
Is an active forum collaborator / developer
xstormfirex wrote:The session 14 will be played through the downloaded file or should you download something else?

Demoniacs!!!!


Yeah just download it and extract it to the D2 folder and you're good to go.
In case it doesn't work, try running the game as admin.
"but if it's simple it's not that hard" - Quirinus 2017
"small things like this are not a big deal" - Quirinus 2017
Lorgard
Destroyer
7 | 0
Can't we update the game without the launcher ?
User avatar
Jakkt
Sasquatch
66 | 7
Common Supporter Badge
Donated 1 time
So, far the Launcher is working great. Thank you, Marco and the Median team. We're incredibly grateful for your time and energy put into this.