MXL Launcher 0.2.8

Discuss Median XL!
User avatar
Quirinus
Gore Crawler
1531 | 134
Common Posting Badge
Posted over 1.000 messages
Common Popularity Badge
Has a thread with over 10.000 views
Great Love Badge
Earned over 100 cookies
Common Supporter Badge
Donated 1 time
Great Contribution Badge
Is an active forum collaborator / developer
Weird that you get no error. It helps though, to narrow the problem down. Thanks!

Oh, maybe 1.14b has Glide included, so that's why.
"but if it's simple it's not that hard" - Quirinus 2017
"small things like this are not a big deal" - Quirinus 2017
halfacandan
Cultist
23 | 1
Excellent knowledge. That's exactly what it was.

(Edit) Here's the fix: https://superuser.com/questions/698037/ ... indows-8-1

Thank you
Dan

Quirinus wrote:
halfacandan wrote:
Quirinus wrote:Anyone with non-English Windows willing to test a new version of the launcher?
I want to see if I fixed the bug that caused it to not work on non-English Windows.


Hi. Not sure whether this is related...

I use a UK Keyboard layout on an English (UK) install of Windows 10 64-bit and I've noticed that the launcher switches my keyboard to the US layout. Not a big deal but it doesn't switch it back to UK after closing the launcher so I have to do it manually.

Hope this helps
Dan


Hello.

That's probably you hitting Left Alt + Shift, which changes the keyboard input language, not the Launcher.
You can either change the key bindings in D2, or Windows (or completely remove the US keyboard input).
Edited by halfacandan 3 months.
User avatar
Quirinus
Gore Crawler
1531 | 134
Common Posting Badge
Posted over 1.000 messages
Common Popularity Badge
Has a thread with over 10.000 views
Great Love Badge
Earned over 100 cookies
Common Supporter Badge
Donated 1 time
Great Contribution Badge
Is an active forum collaborator / developer
You didn't need to remove the keyboard input language, you can just change the keyboard shortcut. (it's a bit hidden in windows 10 though, but it's still there)

Oh well, it's fixed now in any case. :)

Enjoy!
"but if it's simple it's not that hard" - Quirinus 2017
"small things like this are not a big deal" - Quirinus 2017
halfacandan
Cultist
23 | 1
Quirinus wrote:You didn't need to remove the keyboard input language, you can just change the keyboard shortcut. (it's a bit hidden in windows 10 though, but it's still there)

Oh well, it's fixed now in any case. :)

Enjoy!


Meh. The keyboard came back anyway but your suggestion sorted it right out. Here's the link for anyone else who needs it:
https://superuser.com/questions/698037/ ... indows-8-1
User avatar
niqxarn
Prowler
16 | 0
Common Supporter Badge
Donated 1 time
Hi,

I would like to see the startup option "-nofixaspect" to be added.

It's one thing thats keeping me from the launcher at this moment. :-)
stephenseiber
Imp
4 | 0
I found a bug with this. it kept having problems saying it couldnt find patch_d2.mpq. then go and look in the folder and release the game was installed as patch_D2.mpq... renamed the folder to patch_d2.mpq and it installed just find... would suggest it look for either patch_d2.mpq or patch_D2.mpq
MrFunk
Bone Archer
76 | 4
Ok so I love the launcher but I have a really strange problem. It does not give an error or anything but unless I open the options menu before launching it will always launch in a window. Even after I have already set it to open full screen. I don't actually have to click anything, just open the menu, close it, then it will launch as normal.

I am running Windows 10 and I have tried running the program as admin and not and it does the same thing.
User avatar
HechtHeftig
Horadric Mage
1074 | 56
Common Posting Badge
Posted over 1.000 messages
Common Popularity Badge
Has a thread with over 10.000 views
Common Love Badge
Earned over 20 cookies
Common Supporter Badge
Donated 1 time
Common Guide Badge
Created a complete character guide
MrFunk wrote:Ok so I love the launcher but I have a really strange problem. It does not give an error or anything but unless I open the options menu before launching it will always launch in a window. Even after I have already set it to open full screen. I don't actually have to click anything, just open the menu, close it, then it will launch as normal.

I am running Windows 10 and I have tried running the program as admin and not and it does the same thing.


Known issue. We can't fix it unless the launcher gets an update.
User avatar
Quirinus
Gore Crawler
1531 | 134
Common Posting Badge
Posted over 1.000 messages
Common Popularity Badge
Has a thread with over 10.000 views
Great Love Badge
Earned over 100 cookies
Common Supporter Badge
Donated 1 time
Great Contribution Badge
Is an active forum collaborator / developer
Its probably fixed in the next version, since i reworked that whole part of the code.

Im just having some issues with the code that are preventing me from releasing the new version, but it should be out soon.
"but if it's simple it's not that hard" - Quirinus 2017
"small things like this are not a big deal" - Quirinus 2017
EarthBounder
Bone Archer
76 | -1
Common Supporter Badge
Donated 1 time
Quick q -- how does the launcher "- Allows up to 2 instances of Diablo, for muling purposes."? I made a copy of D2 + MXL but the 2nd launcher and the 1st launcher are entirely aware of eachother and prevent a 2nd session.