MXL Launcher 0.3.0

Discuss Median XL!
UnloosedSlice
Skeleton
2 | 0
Hey I'm interested in downloading, I seen it said ANY version of Diablo 2 LoD even the up to date 1.14? Lmk
User avatar
ShadowDawn
Mangler
482 | 29
Common Love Badge
Earned over 20 cookies
Great Supporter Badge
Donated 5 times
Common Guide Badge
Created a complete character guide
UnloosedSlice wrote:Hey I'm interested in downloading, I seen it said ANY version of Diablo 2 LoD even the up to date 1.14? Lmk


The first post in this topic has a download link: http://get.median-xl.com/launcher

When it says "any" version, it means that it can upgrade/downgrade any LoD version to the version that MXL runs on.
UnloosedSlice
Skeleton
2 | 0
ShadowDawn wrote:
UnloosedSlice wrote:Hey I'm interested in downloading, I seen it said ANY version of Diablo 2 LoD even the up to date 1.14? Lmk


The first post in this topic has a download link: http://get.median-xl.com/launcher

When it says "any" version, it means that it can upgrade/downgrade any LoD version to the version that MXL runs on.

Awesome buddy ty
Pandiiten
Fallen
1 | 0
I just downloaded the digital version of D2 and LoD, installed it, downloaded the launcher and, after i click on "install" this happens:

https://www.screencast.com/t/HeyexBJb3

I already tried restarting the launcher 3 times with no luck.

Any ideas?

Edit: forgot to mention, my installation was done on a folder not inside program files.
User avatar
Shame
Prowler
19 | 0
I am getting "UNHANDLED EXCEPTION: PRIV_INSTRUCTION (c0000096)" error.

MXL 2017 version 1.3.1 attempting to play via Launcher version 0.3.0

I am unable to get D2 to even start.