MXL Launcher 0.2.8

Discuss Median XL!
Impervious
Skeleton
2 | 0
lordalexander74 wrote:
Quirinus wrote:
lordalexander74 wrote:New issue: Recently loading the game via the launcher gives me the c0000005 error. Installed on day one onto D2 1.13c, played perfectly since then.

viewtopic.php?f=4&t=4561
A day or so ago, I followed the above guide here to install MXL 2017 w/ D2SE and Plugy for single player, in case my internet connection craps out or I'm on vacation and can't bring my gaming rig. Copied my vanilla D2 files (I've a vanilla D2 install backed up) to another location, and followed that guide. Everything seemed to work fine.

Tried running the launcher today, and encountered that error. I can run MXL and log on to TSW fine with out using the launcher. Only when I started messing around trying to get single player w/ plugy up and running is when I encountered issues. Reinstalling D2 and MXL via launcher didn't help, still can't use the launcher to load D2.

Any idea what I can do to fix this?


c0000005 on hitting multiplayer can be fixed by adding game.exe and Diablo II.exe to the DEP excpetions list. you can find instructions in Menu>Multiplayer>Join (bottom of the page)
c0000005 can be caused by d2se/plugy not being set up properly
c0000005 can be related to video modes missing from registry. you can try running D2VidTst.exe

check that the launcher is using the correct D2 folder path (in launcher settings).
try to set game.exe and Diablo II.exe to run as admin.


Following a complete reinstall of D2 and MXL/launcher, and updating with the new patch, I tried running multiplayer before and after all those suggestions. Thankfully at the end, I could still access TSW through Diablo II.exe, though using the launcher for multiplayer still gives the c0000005 error. That's after checking compatibility, running the .exe files as admin and adding them to the DEP exception list. Still get that error after hitting multiplayer.

Someone suggested trying to add the launcher to the DEP list, but Windows won't let me do that. I can still access TSW, so not using the launcher isn't a big deal. Would like to fix this at some point.

Thanks for the help.


Yeah I'm having a similar issue, tried DEP, admin, vidtest, reinstalling and everything but I can't seem to get multiplayer to work with the launcher without it giving me the c0000005 error. I can play singleplayer just fine through the launcher though.

Also, multiplayer works fine if I just launch directly from Diablo II.exe.

My error.txt says:
"[2017-06-03 20:45:59 -06:00] Error: Command failed: C:\Games\Diablo II\Game.exe -w -3dfx

at ChildProcess.exithandler (child_process.js:223:12)
at emitTwo (events.js:106:13)
at ChildProcess.emit (events.js:191:7)
at maybeClose (internal/child_process.js:885:16)
at Process.ChildProcess._handle.onexit (internal/child_process.js:226:5)"
User avatar
Quirinus
Gore Crawler
1548 | 139
Common Posting Badge
Posted over 1.000 messages
Common Popularity Badge
Has a thread with over 10.000 views
Great Love Badge
Earned over 100 cookies
Common Supporter Badge
Donated 1 time
Great Contribution Badge
Is an active forum collaborator / developer
can you guys try one more thing?

are you both using glide?
go to the properties of glide3x.dll and see if you can find an unblock button maybe

you can try adding glide-init.exe to DEP, but I doubt it will help

you can also try this if you want:
https://forum.median-xl.com/viewtopic.p ... 21#p103321
"but if it's simple it's not that hard" - Quirinus 2017
"small things like this are not a big deal" - Quirinus 2017
lordalexander74
Thunder Beetle
58 | 0
Tried accessing TSW w/ direct3d and glide, still got the error. Couldn't find an unblock button in glide3x.dll properties, and adding glide-init.exe to DEP didn't work either.

Disabling DEP completely seemed to have worked, at least for now. I'll keep you updated if anything changes. Wonder what that'll mean for OS security though, shouldn't be too much of an issue. I run Malwarebytes often and have multiple forms of protection when online.
User avatar
HechtHeftig
Sand Maggot
1164 | 61
Common Posting Badge
Posted over 1.000 messages
Common Popularity Badge
Has a thread with over 10.000 views
Common Love Badge
Earned over 20 cookies
Common Supporter Badge
Donated 1 time
Common Guide Badge
Created a complete character guide
There's a bug (don't know if it's already known):
whenever I start the launcher and then start the game, it is in windowed mode.
Being one of the few people who don't use the windowed mode, It is really annoying having to check and uncheck the windowed mode everytime I start the launcher.

Btw.: Is it possible to add the /nopickup line to the launcher so you don't have to write it in every single game you make? That would really enhance the experience of playing this mod.
Impervious
Skeleton
2 | 0
Quirinus wrote:can you guys try one more thing?

are you both using glide?
go to the properties of glide3x.dll and see if you can find an unblock button maybe

you can try adding glide-init.exe to DEP, but I doubt it will help

you can also try this if you want:
https://forum.median-xl.com/viewtopic.p ... 21#p103321


Well it looks like I went full circle, I set DEP back to the default setting (Turn on DEP for essential Windows programs and services only.) and now the launcher works just fine!
colem4
Destroyer
6 | 0
Hello, just trying to get back into MXL, I did a fresh install of the whole game of D2. Then downloaded the launcher and was prompted to install the MPQ. Ive downloaded it and when i hit the multiplayer button im getting the unhandled exception error Access_Violation (c0000005) Ive put both D2, game.exe, and glide all in the DEP portion to only still encounter the error.

Any tips?

EDIT: I turned DEP on for all programs by selecting the first option and the game works perfectly now. Must be some other program that has to be added to the list that't not being mentioned for windows 10?
MadeLaidMan
Vampiress
36 | 0
I did a fresh install of D2 and before doing anything else I ran the installer and I got the same unhandled exception colem4 did. I couldn't even get to the main menu
User avatar
Jakkt
Pit Knight
112 | 7
Common Supporter Badge
Donated 1 time
Well, I woke up today after zero changes to my system. I can't even open Diablo II now without getting c000005. Which is fucking weird because I was playing this morning. I really don't want to do a damn clean install because I hate finding all my goddamn discs lol.
Ironfly76
Dark Huntress
10 | 1
I followed all the instructions. This is what I get, no matter what I try. Image
User avatar
HechtHeftig
Sand Maggot
1164 | 61
Common Posting Badge
Posted over 1.000 messages
Common Popularity Badge
Has a thread with over 10.000 views
Common Love Badge
Earned over 20 cookies
Common Supporter Badge
Donated 1 time
Common Guide Badge
Created a complete character guide
Ironfly76 wrote:I followed all the instructions. This is what I get, no matter what I try. Image


It looks like D2se is interferring with the launcher. Have you tried de-installing d2se?