MXL Launcher 0.2.8

Discuss Median XL!
axtroz
Imp
5 | 0
Hey, is it possible to add an option to enable '/nopickup' from the launcher?
User avatar
evil_potato
Djinn
516 | 50
Great Popularity Badge
Has a thread with over 50.000 views
Common Love Badge
Earned over 20 cookies
Common Guide Badge
Created a complete character guide
genei wrote:Image

LOL


You using xp? known issue. fix should come at end of development iirc. We're a minority :(
Plyabla
Fallen
1 | 0
When I start launcher, it says 'unknown version' and i can only restart it.

https://drive.google.com/file/d/0B3d3nT ... sp=sharing
Errorlog ^
Win10
Diablo 2 without d2se, just replaced MPQ file.
Eittin
Imp
5 | 0
Launcher looks really nice, simple and easy to use. Only issue I had with it is clicking on "settings". At first it only darkened the launcher and nothing came up. I reopened the launcher and was working fine after that.

system: windows 10
running as admin
User avatar
notforkeeps
Bone Archer
72 | 1
Common Supporter Badge
Donated 1 time
launcher does not open when clicked on. Running win 10.
User avatar
Rishab
Amazon Warrior
1654 | 117
Common Posting Badge
Posted over 1.000 messages
Common Popularity Badge
Has a thread with over 10.000 views
Great Love Badge
Earned over 100 cookies
Common Contribution Badge
Has collaborated to our forums, realms or mod
notforkeeps wrote:launcher does not open when clicked on. Running win 10.

R u running it as an admin?
MXLU Bestiary| Useful BBcodes| Median Discord
Be the change you want to see in this forum.
- Gandhi
momope
Jungle Hunter
27 | 2
Is source code available for the launcher? I feel uncomfortable running executables as administrator otherwise
User avatar
Quirinus
Blood Golem
1370 | 122
Common Posting Badge
Posted over 1.000 messages
Common Popularity Badge
Has a thread with over 10.000 views
Great Love Badge
Earned over 100 cookies
Common Supporter Badge
Donated 1 time
Great Contribution Badge
Is an active forum collaborator / developer
halfacandan wrote:@Quirinus A big thank you for the excellent launcher tool: it simplifies everything. Thanks to it, this is the first time I've managed to play median with Glide graphics. I hadn't realised how excellent D2 could look.


haha you're welcome
marco had the same reaction, he always had problems with glide until he ran d2 with the launcher :mrgreen:

HechtHeftig wrote:
Rishab wrote:
HechtHeftig wrote:I updated now from 2.4.3 to 2.6 but it doesn't work anymore. Am I supposed to delete the earlier update first?

U should try that, older version might be screwing something up


Well, I tried it a couple of times now. Still not starting at all, even after deleting the median XL folder in my diablo folder.

That's weird because 2.4 worked.

Edit: hmm... when I close the program in the task manager, I can see it's 32 Bit. But my PC has a 64 Bit system.

EDIT2: installed 2.4 again and that one works. What did you guys do? :D 2.4 is 32 bit as well so that isn't the problem


Deleting shouldn't be necessary, but try uninstalling and deleting, then installing the new one, preferably not in program files. Restart computer, and run it as admin.

axtroz wrote:Hey, is it possible to add an option to enable '/nopickup' from the launcher?


No, it's waaay too complicated to do.

Plyabla wrote:When I start launcher, it says 'unknown version' and i can only restart it.

https://drive.google.com/file/d/0B3d3nT ... sp=sharing
Errorlog ^
Win10
Diablo 2 without d2se, just replaced MPQ file.


Weird. Do you have admin rights? Try running the launcher as admin.
Are your windows in another language?

Eittin wrote:Launcher looks really nice, simple and easy to use. Only issue I had with it is clicking on "settings". At first it only darkened the launcher and nothing came up. I reopened the launcher and was working fine after that.

system: windows 10
running as admin


It's a known issue, but thanks for reporting. It should probably be fixed in the next version.

notforkeeps wrote:launcher does not open when clicked on. Running win 10.


Restart the computer and try again. Run it as admin. Preferably don't install it in the program files.

momope wrote:Is source code available for the launcher? I feel uncomfortable running executables as administrator otherwise


No.
I mean, I don't really need admin rights to mess up a computer or install some form of malware if I wanted to. :mrgreen:
And people have been running all sorts of 3rd party tools for years without the source code already.
This one is official, from us, it's not like it's from some random dude on the internet, but if you don't trust us, just don't run it, it's not like it's mandatory to run it to get MXL going. Plus, I already did a few tools before, and no one complained (true, they had source code, but still) - and you can see no one is having any complaints about the launcher doing nefarious things in this thread.
In the next 1-2 versions, I'll try to make it not need admin rights to run, so maybe wait until then.
"but if it's simple it's not that hard" - Quirinus 2017
"small things like this are not a big deal" - Quirinus 2017
User avatar
HechtHeftig
Core Lord
396 | 27
Common Love Badge
Earned over 20 cookies
Common Supporter Badge
Donated 1 time
Common Guide Badge
Created a complete character guide
Quirinus wrote:
HechtHeftig wrote:
Rishab wrote:
HechtHeftig wrote:I updated now from 2.4.3 to 2.6 but it doesn't work anymore. Am I supposed to delete the earlier update first?

U should try that, older version might be screwing something up


Well, I tried it a couple of times now. Still not starting at all, even after deleting the median XL folder in my diablo folder.

That's weird because 2.4 worked.

Edit: hmm... when I close the program in the task manager, I can see it's 32 Bit. But my PC has a 64 Bit system.

EDIT2: installed 2.4 again and that one works. What did you guys do? :D 2.4 is 32 bit as well so that isn't the problem


Deleting shouldn't be necessary, but try uninstalling and deleting, then installing the new one, preferably not in program files. Restart computer, and run it as admin.


Thanks! Works now!
Beepr
Dark Huntress
11 | 0
So I have the launcher installed and working, but everything is incredibly slow. when i start D2 it takes around 1-2 minutes for it to load up and the window goes (Not Responding) for a period of time before eventually working. When it eventually loads up joining games is way slower than when using d2se both sp and tsw. Is this normal? Any idea why it would be acting like this if its not normal?