MXL Launcher 0.2.8

Discuss Median XL!
User avatar
Quirinus
Gore Crawler
1505 | 130
Common Posting Badge
Posted over 1.000 messages
Common Popularity Badge
Has a thread with over 10.000 views
Great Love Badge
Earned over 100 cookies
Common Supporter Badge
Donated 1 time
Great Contribution Badge
Is an active forum collaborator / developer
@HechtHeftig: awesome!

Beepr wrote:So I have the launcher installed and working, but everything is incredibly slow. when i start D2 it takes around 1-2 minutes for it to load up and the window goes (Not Responding) for a period of time before eventually working. When it eventually loads up joining games is way slower than when using d2se both sp and tsw. Is this normal? Any idea why it would be acting like this if its not normal?


The D2 window is not responding, or the launcher window? Are you running glide? If you go to glide settings, is "Keep desktop composition" on? Turn it off.

What windows are you using?
"but if it's simple it's not that hard" - Quirinus 2017
"small things like this are not a big deal" - Quirinus 2017
User avatar
NikafieNd
Azure Drake
173 | 3
Great Supporter Badge
Donated 5 times
Only just been able to try it today. Everything's running fine on my end, Window 10 and with Glide setting.

Looks great, nice job Quirinus. :flip:
User avatar
giuzera
Dark Huntress
13 | -1
Hello, I'm having trouble with the launcher. I installed it with the permission of administrator. And also executed the shortcut with the permission. But only the restart button continues to appear.

Windows 10 pro
Diablo II folder without any changes.
(E:\Jogos\Diablo II\Median XL) - Path where the launcher was installed

Print
► Show Spoiler



My error log.
► Show Spoiler
Beepr
Dark Huntress
11 | 0
Quirinus wrote:@HechtHeftig: awesome!

Beepr wrote:So I have the launcher installed and working, but everything is incredibly slow. when i start D2 it takes around 1-2 minutes for it to load up and the window goes (Not Responding) for a period of time before eventually working. When it eventually loads up joining games is way slower than when using d2se both sp and tsw. Is this normal? Any idea why it would be acting like this if its not normal?


The D2 window is not responding, or the launcher window? Are you running glide? If you go to glide settings, is "Keep desktop composition" on? Turn it off.

What windows are you using?


The D2 window was the one not responding.Windows 10. Yes Im using Glide. Keep desktop composition is turned off

started D2 from the launcher after checking the settings and everything is working as fast as d2se now (-: (-: (-: yay technology
User avatar
HechtHeftig
Detonator
794 | 42
Common Love Badge
Earned over 20 cookies
Common Supporter Badge
Donated 1 time
Common Guide Badge
Created a complete character guide
Quirinus wrote:@HechtHeftig: awesome!


Not very awesome because d2se stopped working... Even after deinstalling the launcher, reinstalling d2se and restarting pc... not working anymore... now basically my whole progress in SP is gone...
Beepr
Dark Huntress
11 | 0
HechtHeftig wrote:
Quirinus wrote:@HechtHeftig: awesome!


Not very awesome because d2se stopped working... Even after deinstalling the launcher, reinstalling d2se and restarting pc... not working anymore... now basically my whole progress in SP is gone...


As long as you backed up your saves folder when you get it reinstalled and working you can just pick up where you left off
NurseJared
Cultist
21 | 0
Common Supporter Badge
Donated 1 time
Wow - I've never seen D2 at 75FPS! Launcher somehow fixed glide.

Smooth as glass.
User avatar
void
Polar Worm
1847 | 67
Common Posting Badge
Posted over 1.000 messages
Common Love Badge
Earned over 20 cookies
Common Guide Badge
Created a complete character guide
HechtHeftig wrote:
Quirinus wrote:@HechtHeftig: awesome!


Not very awesome because d2se stopped working... Even after deinstalling the launcher, reinstalling d2se and restarting pc... not working anymore... now basically my whole progress in SP is gone...

this is what is was worried about when using launcher

idk what is causing this but if the launcher interferes with d2se then it would make sense to fix that

it looks like launcher has decent functionalities, and you dont have to care about users who want to play other mods/old mxl versions with d2se, but its still a middle finger to mxl fans who like to play other mods on the side with d2se before ladder resets. i was talking to marco and he doesnt care, so i guess the only way to maybe turn this around is to have enough ppl complain about it
User avatar
HechtHeftig
Detonator
794 | 42
Common Love Badge
Earned over 20 cookies
Common Supporter Badge
Donated 1 time
Common Guide Badge
Created a complete character guide
Beepr wrote:
HechtHeftig wrote:
Quirinus wrote:@HechtHeftig: awesome!


Not very awesome because d2se stopped working... Even after deinstalling the launcher, reinstalling d2se and restarting pc... not working anymore... now basically my whole progress in SP is gone...


As long as you backed up your saves folder when you get it reinstalled and working you can just pick up where you left off


Yeah luckily I did that. Anyway, I send a pm to seltsamuel... hopefully he'll answer me soon.

@void yes for me it was the same. I only started installing it when 2.4 was out because I thought "okay nobody complained so far" and that most bugs must've been fixed... Guess I was wrong :cry:
User avatar
HechtHeftig
Detonator
794 | 42
Common Love Badge
Earned over 20 cookies
Common Supporter Badge
Donated 1 time
Common Guide Badge
Created a complete character guide
Update:

Okay d2se works again. Looks like I somehow turned off the compatibility mode without going to settings.

But now the launcher doesn't work, even after restarting.