MXL Launcher 0.2.8

Discuss Median XL!
User avatar
Aeronic
Dark Huntress
14 | 5
Common Supporter Badge
Donated 1 time
I'm almost guaranteed to be on my own on this problem but the launcher fails to run after installation using the latest wine on Linux. I like the idea of a dedicated launcher to make the whole process easier on users but making it mandatory seems a bit too much. There are plenty of advanced users that can handle setting up the mod themselves and in my case it could possibly not allow me to play the mod.
User avatar
-----
Thunder Beetle
58 | 1
Aeronic wrote:I'm almost guaranteed to be on my own on this problem but the launcher fails to run after installation using the latest wine on Linux. I like the idea of a dedicated launcher to make the whole process easier on users but making it mandatory seems a bit too much. There are plenty of advanced users that can handle setting up the mod themselves and in my case it could possibly not allow me to play the mod.


It works for linux if you use WINE staging 2.7, 32-bit WINEPREFIX. Download the patch yourself and place in d2 install folder (currently at http://get.median-xl.com/launcher/mod_full/16.1.0.7z). Check median\ xl/resources/external for batch scripts which help show how the launcher updates the game. you will have to add some registry entries yourself. I think HKCU is the same as user.reg in your wineprefix. You'll know which keys you need to add because an error will show up in error_log.txt when the launcher tries to add them.

I hope this will be fine with the new patch too. Keep an eye on http://get.median-xl.com/launcher/get_version.php for a new version string and replace the version in the above url with the 7z file to download the patch. Someone can tell us their median_version in settings.json after the update, too. Now I am curious how they will enforce using the launcher on the new patch. Or you can go to launcher/mod_updates/{version}.update for a VCDIFF instead of downloading the whole mod.

By the way @quirinius if you close the launcher before the download is complete then the launcher will attempt to install with the *.part file on next startup and crash out. you have to delete the *.part by hand
loc89
Core Lord
395 | -4
Legendary Supporter Badge
Donated 25 times
Question, I'm sure someone answered this but does this launcher work Ron mac installed versions ?
User avatar
ShadowDawn
Heretic
433 | 22
Common Love Badge
Earned over 20 cookies
Great Supporter Badge
Donated 5 times
Will this launcher be able to use old versions of the game after it's full release?

Sometimes i like to go back and play old versions of MXL, and i can do that very easily with D2SE.

But the launcher will be required for Sigma, and not being able to play old patches of it if you so wish, would suck big time.
User avatar
Jampula
Onyx Knight
616 | 23
Common Love Badge
Earned over 20 cookies
Common Supporter Badge
Donated 1 time
ShadowDawn wrote:Will this launcher be able to use old versions of the game after it's full release?

Sometimes i like to go back and play old versions of MXL, and i can do that very easily with D2SE.

But the launcher will be required for Sigma, and not being able to play old patches of it if you so wish, would suck big time.

You can always have two copies of D2 installed... one for D2SE and one strictly for launcher.


I myself have four copies, each serving it's own purprose.
User avatar
ShadowDawn
Heretic
433 | 22
Common Love Badge
Earned over 20 cookies
Great Supporter Badge
Donated 5 times
Jampula wrote:
ShadowDawn wrote:Will this launcher be able to use old versions of the game after it's full release?

Sometimes i like to go back and play old versions of MXL, and i can do that very easily with D2SE.

But the launcher will be required for Sigma, and not being able to play old patches of it if you so wish, would suck big time.

You can always have two copies of D2 installed... one for D2SE and one strictly for launcher.


I myself have four copies, each serving it's own purprose.


I already have that, and that's not the problem.

The problem is here:

Marco wrote:This app will eventually become the standard and mandatory way to run Median.


Meaning that it's the only way to run Sigma. You won't be able to run Sigma with D2SE.

If i want to go back and play the first Sigma release a few years down the line (Like i do with Omega version atm), then i would not be able to unless the launcher supports old versions.
Dradar
Vampiress
39 | 0
Common Supporter Badge
Donated 1 time
For some reason when I launch D2 through the Median XL launcher I'm not able to assign mouse wheel up/down in key bindings, but if I launch D2 without the launcher I can. Anyone know what might fix this?
User avatar
Zennith
Monkey King
272 | 14
Great Supporter Badge
Donated 5 times
Common Patron Badge
Patreon Contributor
Dradar wrote:For some reason when I launch D2 through the Median XL launcher I'm not able to assign mouse wheel up/down in key bindings, but if I launch D2 without the launcher I can. Anyone know what might fix this?


I had a similar issue without the launcher when I tried to run Diablo 2 with no compatibility modes set. Try setting compatibility mode to XP Service pack 2 and see if that works if it's not already set maybe?
Dradar
Vampiress
39 | 0
Common Supporter Badge
Donated 1 time
Zennith wrote:
Dradar wrote:For some reason when I launch D2 through the Median XL launcher I'm not able to assign mouse wheel up/down in key bindings, but if I launch D2 without the launcher I can. Anyone know what might fix this?


I had a similar issue without the launcher when I tried to run Diablo 2 with no compatibility modes set. Try setting compatibility mode to XP Service pack 2 and see if that works if it's not already set maybe?

I have the launcher set to run like that, because thats was how I got D2 to do it normally, but it doesnt work for the launcher. So I'm guessing the launcher launches in compatibility mode but then launches the game not in it
User avatar
Jaxon
Grubber
329 | 10
the launcher didnt work so i reinstalled d2 + lod and installed the mxl launcher. this is what happens when i launch it as admin and wo admin:

Image
Edited by Jaxon 6 months.