MXL Launcher 0.3.1

Discuss Median XL!
User avatar
Templayer
Skeleton
2 | 0
So I just tried the launcher, and it gave me an error: "This program does not support the version of Windows your computer is running."
I'm running Windows XP SP3, 32-bit.


And before anybody starts a stupid flame war about "yur usyng old operatyng sistem, uprage to Wyndows 10, teh best operatyng sistem evar!",
I'll tell you that I have my XP 32-bit dual-booted with a Windows 7 64-bit. For all the games I like, but cannot run on XP (all six of them). However I only use that if I have to, and a Diablo 2 mod shouldn't be like that...

I do have all the .net frameworks installed up to 4 (including 4), and all the c++ redistributables up to 2015, and newest directx 9, of course.

EDIT: I just realized that I am technically running a Windows WEPOS / POSReady (essentially an XP SP3 that is supported by automatic updates up until 2019), which might be why the installer is b*tching. (but this is the very first time I came across that if it indeed is the source of the problem).
User avatar
Unda
Son of Lucion
738 | 18
Templayer wrote:So I just tried the launcher, and it gave me an error: "This program does not support the version of Windows your computer is running."
I'm running Windows XP SP3, 32-bit.


And before anybody starts a stupid flame war about "yur usyng old operatyng sistem, uprage to Wyndows 10, teh best operatyng sistem evar!",
I'll tell you that I have my XP 32-bit dual-booted with a Windows 7 64-bit. For all the games I like, but cannot run on XP (all six of them). However I only use that if I have to, and a Diablo 2 mod shouldn't be like that...

I do have all the .net frameworks installed up to 4 (including 4), and all the c++ redistributables up to 2015, and newest directx 9, of course.

EDIT: I just realized that I am technically running a Windows WEPOS / POSReady (essentially an XP SP3 that is supported by automatic updates up until 2019), which might be why the installer is b*tching. (but this is the very first time I came across that if it indeed is the source of the problem).


The setup will now refuse to install if running on Windows XP (as the Launcher doesn't work there).

Source: Under "Other changes" viewtopic.php?p=183882#p183882
credomane
Imp
4 | 0
Haven't played in a few months. Just updated the launcher to 0.3.1 but it won't update the game to 1.3 I'm stuck at "Median 2017 1.2.0.1". I click update the download bar flashes on the screen then it update changes to restart. Click restart and the launcher relaunches. I can repeat this over and over and over. Nothing ever changes or happens. Looking at the d2 install folder the launcher is creating a 2MB file named "17.6.0.update" and modifies d2gfx.dll to be 76KB in size.

There is never a log file made to see what it going on either. Doesn't seem to be any update issues mentioned anywhere on the forums or the internet at large. What can i do to fix this or at the very least provide more info to get this resolved?

[edit]
Finally managed to find a page that mentions that with the update to the 0.3.1 launcher you are required to manually delete patch_d2.dll. No offense but that is kinda big step backwards in terms of ability and purpose of the updater don't you think? Shouldn't the updater be able to handle updating the game without help?
User avatar
Templayer
Skeleton
2 | 0
Unda wrote:
Templayer wrote:So I just tried the launcher, and it gave me an error: "This program does not support the version of Windows your computer is running."
I'm running Windows XP SP3, 32-bit.


And before anybody starts a stupid flame war about "yur usyng old operatyng sistem, uprage to Wyndows 10, teh best operatyng sistem evar!",
I'll tell you that I have my XP 32-bit dual-booted with a Windows 7 64-bit. For all the games I like, but cannot run on XP (all six of them). However I only use that if I have to, and a Diablo 2 mod shouldn't be like that...

I do have all the .net frameworks installed up to 4 (including 4), and all the c++ redistributables up to 2015, and newest directx 9, of course.

EDIT: I just realized that I am technically running a Windows WEPOS / POSReady (essentially an XP SP3 that is supported by automatic updates up until 2019), which might be why the installer is b*tching. (but this is the very first time I came across that if it indeed is the source of the problem).


The setup will now refuse to install if running on Windows XP (as the Launcher doesn't work there).

Source: Under "Other changes" http://forum.median-xl.com/viewtopic.ph ... 82#p183882


Well, I managed to get the newest Median XL version working without it. Why isn't the launcher supported for Windows XP, while XP is the best system to play Diablo 2 on, is something that I do not understand. (my friend (the one with which I'm planning to play it with) had quite a few problems running it on Windows 7 that do not exist on XP, as far as I know, like having to wait 10 minutes before the game starts etc. Solved, but it would be nice not to have to solve them...)
User avatar
Solfege
Mahasattva
929 | 127
Great Popularity Badge
Has a thread with over 50.000 views
Great Love Badge
Earned over 100 cookies
Common Guide Badge
Created a complete character guide
Will the Launcher to be the only way to play Sigma? (I honestly can't remember.) And if so, will there be a Linux-compatible version of it by release date? I know it's not really a priority since there are, what, less than a half-dozen of us rogue Linux users. I just wanna know if I'll need to have a Windows machine ready.
User avatar
Quirinus
Team Member
1697 | 162
Common Posting Badge
Posted over 1.000 messages
Common Popularity Badge
Has a thread with over 10.000 views
Great Love Badge
Earned over 100 cookies
Common Supporter Badge
Donated 1 time
The Launcher will be the main way to play Sigma, but you will probably still be able to not use it.

I don't have plans on doing a Linux version since I don't use Linux and Wine. That's one of the reasons I open sourced the code, so people can do the odd thing like that by themselves, and then contribute back.
"but if it's simple it's not that hard" - Quirinus 2017
"small things like this are not a big deal" - Quirinus 2017
User avatar
Solfege
Mahasattva
929 | 127
Great Popularity Badge
Has a thread with over 50.000 views
Great Love Badge
Earned over 100 cookies
Common Guide Badge
Created a complete character guide
Understandable. You guys are busy enough as it is. Also didn't notice you made it open-source. That's cool. I'm not much of a programmer, but I'd be willing to see what I can do to make it work when I have some free time.
User avatar
Unda
Son of Lucion
738 | 18
credomane wrote:Haven't played in a few months. Just updated the launcher to 0.3.1 but it won't update the game to 1.3 I'm stuck at "Median 2017 1.2.0.1". I click update the download bar flashes on the screen then it update changes to restart. Click restart and the launcher relaunches. I can repeat this over and over and over. Nothing ever changes or happens. Looking at the d2 install folder the launcher is creating a 2MB file named "17.6.0.update" and modifies d2gfx.dll to be 76KB in size.

There is never a log file made to see what it going on either. Doesn't seem to be any update issues mentioned anywhere on the forums or the internet at large. What can i do to fix this or at the very least provide more info to get this resolved?

[edit]
Finally managed to find a page that mentions that with the update to the 0.3.1 launcher you are required to manually delete patch_d2.dll. No offense but that is kinda big step backwards in terms of ability and purpose of the updater don't you think? Shouldn't the updater be able to handle updating the game without help?


It was not required to delete patch_d2.mpq with update to the 0.3.1 launcher, I did both updates simultaneously using launcher, first launcher update from 0.3.0 to 0.3.1 using green Restart popup and then game from MXL 1.3.1 to 1.3.2 patch using Update without problems. The thing is that launcher 0.3.1 was released after MXL 1.3 patch so most people who was updating to 1.3.2 had 1.3.x actually, it was highly unlikely that problems with updating from 1.1 and 1.2 versions using launcher 0.3.1 will be found. Ofc I tested that now and 0.3.1 not updating from 1.1.3 and 1.2.0.1 patches (had no other versions on disc to test).

All im saying is that we all here are testers and helping Quirinus with reports and troubleshooting to make this app perfect before Sigma release and we shouldnt be upset because some error occured.

Good credomane that you learned that patch_d2.mpq is main mod file and when you download mod manually from ModDB https://get.median-xl.com/ you can find all files necessary to go, that file can get corrupted during DL, update etc. so your first guess when similar thing happen is that you should replace that file or delete and let launcher update it from scratch.

@Quirinus, I dont know if anyone else in future will face problem that credomane had but you can add info to main thread (temporary till new release) that Launcher 0.3.1 will not update MXL patch from versions 1.1 and 1.2, which require deleting patch_d2.mpq to start updating.
direkenz
Imp
5 | 0
Hi first thing first.

Where can i find on how to use this new software? Unlike before, installing median is by just overwriting the mov files..

Now, how to use this in a fresh windows 7 PC.

Appreciate for your feedbacks.
mrd5213
Skeleton
2 | 0
Hello guys, i have this problem when i installed MXL launcher adn updated, then opened it and it said " failed to retrieve process" so i went ahead and change compatibility mode to window xp service pack 3, then launched it again but this time , nothing happened. i can see it running in the background via my task manager, i click end task then open it again, but still nothing happen. pls help me.