MXL Launcher 0.3.1

Discuss Median XL!
KaliszM
Cultist
20 | 0
Here is bug that I encounter right after I start the launcher.

Image
User avatar
Quirinus
Amazon Warrior
1690 | 162
Common Posting Badge
Posted over 1.000 messages
Common Popularity Badge
Has a thread with over 10.000 views
Great Love Badge
Earned over 100 cookies
Common Supporter Badge
Donated 1 time
Great Contribution Badge
Is an active forum collaborator / developer
Talic wrote: I guess we didn't understand each other.

As you said "The launcher will replace patch_d2.mpq with the median xl one and D2 game.exe with the 1.13c version".

I did noticed that, since I was unable to install 1.13c patch which was saying that I already have 1.13c version.

But as I said, for Median Xl Launcher to properly work. you need to have a patch_d2.mpq in your game folder, I didn't had that since my diablo 2 setup files are very, very old where after installation you don't have patch_d2.mpq in your game folder.

You see, that was the problem, launcher is looking for file that doesn't exist, at least in my case.

After I read .log file created by launcher it was easy to solve that problem by just installing some patch, 1.13d in my case, after that all worked just fine.


Thank You once again, launcher is really nice. :clap: :thumb:


Thanks, it will be solved in the next version. :)
Though I don't know why you would have a D2 folder without patch_d2.mpq. xD

KaliszM wrote:Here is bug that I encounter right after I start the launcher.

Image


It will be solved in the next version. Right now, to fix it, you should put D2VidTst.exe in the D2 folder, as pointed out by Kyromyr before.

http://get.median-xl.com/launcher/D2VidTst.exe
"but if it's simple it's not that hard" - Quirinus 2017
"small things like this are not a big deal" - Quirinus 2017
User avatar
Talic
Cog
236 | 17
► Show Spoiler


Why, because I only installed diablo 2 right now to test the launcher, to provide some "feedback".

I'm curious why some have D2VidTst.exe outside D2 folder, it is by default in it, right. :scratch:
User avatar
HornedReaper
Acid Prince
46 | 1
I tried it but avast is being picky : it gets terminated and can't be launched because the source is "untrusted" yet. I don't thing you can do anything though Quirinus, but i still wanted to post about it so you know.
Can't wait to get back to medianXL (2017), I'm pumped!
User avatar
Quirinus
Amazon Warrior
1690 | 162
Common Posting Badge
Posted over 1.000 messages
Common Popularity Badge
Has a thread with over 10.000 views
Great Love Badge
Earned over 100 cookies
Common Supporter Badge
Donated 1 time
Great Contribution Badge
Is an active forum collaborator / developer
Talic wrote:
► Show Spoiler


Why, because I only installed diablo 2 right now to test the launcher, to provide some "feedback".

I'm curious why some have D2VidTst.exe outside D2 folder, it is by default in it, right. :scratch:


D2 1.14 removes D2VidTst.exe, older versions have it

HornedReaper wrote:I tried it but avast is being picky : it gets terminated and can't be launched because the source is "untrusted" yet. I don't thing you can do anything though Quirinus, but i still wanted to post about it so you know.
Can't wait to get back to medianXL (2017), I'm pumped!


Thanks. You can probably mark it as "trusted" or put it on the whitelist in the antivirus, it should let you launch it then.
"but if it's simple it's not that hard" - Quirinus 2017
"small things like this are not a big deal" - Quirinus 2017
User avatar
HornedReaper
Acid Prince
46 | 1
So I will post an update:
Every thing is working perfectly right now so far.
Wierdly the installer only worked (install+ run game without crash) when my game path was changed to "D:\Games\Diablo II\Diablo II"
Anyway thanks for the launcher, great job!
User avatar
Zennith
Monkey King
293 | 16
Common Popularity Badge
Has a thread with over 10.000 views
Great Supporter Badge
Donated 5 times
Got a weird issue and idk why the launcher is causing it, but... /fps isn't working for me in-game when using the launcher. D2SE allows me to /fps in game. But when I use the launcher to launch D2, /fps no longer works in game.

This is on realm, only differences is D2se vs MXL Launcher 0.2.2

I am using Glide on both D2SE and MXL Launcher.

Can anyone else confirm this so I know I'm not alone with this issue?
User avatar
Quirinus
Amazon Warrior
1690 | 162
Common Posting Badge
Posted over 1.000 messages
Common Popularity Badge
Has a thread with over 10.000 views
Great Love Badge
Earned over 100 cookies
Common Supporter Badge
Donated 1 time
Great Contribution Badge
Is an active forum collaborator / developer
Version 0.2.3 has been released.

You can download it from the same link:
http://get.median-xl.com/launcher

Changes:
- installer no longer has problems running the launcher after install
- fixed missing D2VidTst.exe wrong path problem
- will offer to install Median XL (patch_d2.mpq) if it's missing
- fixed settings soft-locking the main window
- launcher no longer sets compatibility and other options on game.exe, you can do it manually if you want
- pushed effect on the play button
- other misc fixes and improvements

Note:
- If your Windows changes appearance when running Glide (and you dont like it), turn on "Keep desktop composition" in the Launcher --> Settings --> Glide Settings. It can cause the game to freeze on some computers though.
- It's preferable to not install the Launcher nor D2 in Program Files.
"but if it's simple it's not that hard" - Quirinus 2017
"small things like this are not a big deal" - Quirinus 2017
Kyromyr
Cog
200 | 100
Great Popularity Badge
Has a thread with over 50.000 views
Great Love Badge
Earned over 100 cookies
Common Contribution Badge
Has collaborated to our forums, realms or mod
Clicking on settings causes a soft-lock if launcher was run without admin privilege (such as when starting from installer). Closing the settings window by pressing alt-F4 also causes a soft-lock.
User avatar
Quirinus
Amazon Warrior
1690 | 162
Common Posting Badge
Posted over 1.000 messages
Common Popularity Badge
Has a thread with over 10.000 views
Great Love Badge
Earned over 100 cookies
Common Supporter Badge
Donated 1 time
Great Contribution Badge
Is an active forum collaborator / developer
Kyromyr wrote:Clicking on settings causes a soft-lock if launcher was run without admin privilege (such as when starting from installer). Closing the settings window by pressing alt-F4 also causes a soft-lock.


Weird. I'll check it out when I get home. Thanks.

Edit: Ah, I think I know what's going on.
"but if it's simple it's not that hard" - Quirinus 2017
"small things like this are not a big deal" - Quirinus 2017