FPS drops

Need help installing the mod?
HitZ
Prowler
15 | 0
I will make it short, is it normal that the game drops from 400-500 fps to 15-30 fps at a times (not even a big fights like cow level)? I got a decent pc (i7 7th gen) and gtx 1070 ?
User avatar
lubronbrons
Banned
36 | -4
I assume you know D2 have parameter -act5 right ?
if performance is your issue maybe you could try this parameter
-lq
or
-lowquality
maybe with that you could get more performance
or even use force framerate feature just after that lq, to get more
example :
-fr 25
(because D2 is at 25 fps standard)
example of real use on shortcut :
"C:\Games\Diablo II\Diablo II.exe" -w -lq -direct -fr 25
for more info read
source : http://diablo.wikia.com/wiki/Game_commands
Edited by lubronbrons 5 months.
User avatar
Gekko64
Astral Guardian
1940 | 100
Common Posting Badge
Posted over 1.000 messages
Great Love Badge
Earned over 100 cookies
Common Supporter Badge
Donated 1 time
try adding -ns to your d2 shortcut, disabling sound effects makes the game run a lot faster
HitZ
Prowler
15 | 0
I'm using glide which should yield better performance with -ns enabled in d2se? I'm using latest windows 10, also all d2 folder executables are run as admin with compatibility win xp sp3 (tried windows 7) as well. Still, performance is shit, the nasty fps drops even occur when I'm running in town. I remember a few years ago playing on my amd pc with win 7 and didn't have such problems, the game was smooth and enjoyable. I kinda crave playing median again, but those problems are pretty discouraging.
User avatar
lubronbrons
Banned
36 | -4
CMIIW
direct draw is the best performance (worst visual)
while glide have much better visual but cost performance
if visual is not that important to you, then I suggest that you use direct draw for you D2
User avatar
Solfege
Mahasattva
912 | 126
Great Popularity Badge
Has a thread with over 50.000 views
Great Love Badge
Earned over 100 cookies
Common Guide Badge
Created a complete character guide
@HitZ
Try adjusting your Glide settings. For me, enabling V-Sync and setting the right texture-memory and buffer-texture-size make the biggest differences for decent fps. As Gekko said, -ns is an option, but just turning the music off via in-game slider can give fps a boost too.
HitZ
Prowler
15 | 0
Mind sharing your glide settings @solfege? Tried ddraw, same thing as others.
User avatar
Solfege
Mahasattva
912 | 126
Great Popularity Badge
Has a thread with over 50.000 views
Great Love Badge
Earned over 100 cookies
Common Guide Badge
Created a complete character guide
Sure.

► Show Spoiler

My PC isn't nearly as good as yours (Core 2 Duo e8400, gt 630), but these settings work for me. I still get some stuttering, especially in heavy combat, but that probably has more to do with being on Linux and having to run the game through WINE.
KeYzBeZ
Prowler
15 | 0
having the same fps drops windows 10 1.13c patch