How to set up GLIDE WRAPPER + Borderless window (pimp your mxl)

Find a handful of guides and walkthroughs here!
Akyrios
Imp
4 | 0
Image
User avatar
Taem
Shadowgate Totem
1713 | 43
Common Posting Badge
Posted over 1.000 messages
Great Popularity Badge
Has a thread with over 50.000 views
Common Love Badge
Earned over 20 cookies
Common Supporter Badge
Donated 1 time
For some reason, when I play in windowed mode, the game moves at a snails pace, rather I keep DESKTOP COMPOSITION on or off, so I can only play it in full screen. None of this bothers me. What bothers me is I have a dual monitor setup and the game always displays on my laptop monitor instead of my much larger monitor. How can I get D2 to show up on my other monitor instead of rendering on my laptop without the obvious (i.e. cloning the screen, since that'll reduce the image size)?
User avatar
Warren1001
Monkey King
285 | 10
Great Popularity Badge
Has a thread with over 50.000 views
Common Contribution Badge
Has collaborated to our forums, realms or mod
Taem wrote:For some reason, when I play in windowed mode, the game moves at a snails pace, rather I keep DESKTOP COMPOSITION on or off, so I can only play it in full screen. None of this bothers me. What bothers me is I have a dual monitor setup and the game always displays on my laptop monitor instead of my much larger monitor. How can I get D2 to show up on my other monitor instead of rendering on my laptop without the obvious (i.e. cloning the screen, since that'll reduce the image size)?

Since Diablo 2 is outdated, it will always full screen on whatever is designated as "Main" monitor. I'm not sure if its possible with a laptop, but try looking into your screen and resolution settings on Windows or whatever you're using and try setting your other monitor to Main.
Tankosaurus
Destroyer
7 | 0
When I did this I had an issue where my mouse would be boxed in from the right side of the game window. The mouse acted as if the last 100 pixels of hte game werent within the box and couldnt move to the outmost right side of the screen.

Anyone else have this issue or a fix
Burako
Fallen
1 | 0
Tankosaurus wrote:When I did this I had an issue where my mouse would be boxed in from the right side of the game window. The mouse acted as if the last 100 pixels of hte game werent within the box and couldnt move to the outmost right side of the screen.

Anyone else have this issue or a fix


I had the same problem but going into the Glide settings and enabling "capture mouse" under settings fixed my issue.
Fenric
Cultist
23 | 0
I followed the instructions + the post regarding 1920x1080 monitor, but it doesn't stretch the D2 window. Instead it adds black borders around it to reach the specified resolution, which is pointless.

Also, if anyone has any ideas. I'm having an issue with the game stuttering. It's quite noticeable when moving, and the fast pace of MXL makes it stand out even more. I've been messing with the glide wrapper settings, running fullscreen, using nvidia control panel vsync instead, etc. Nothing has made a difference, and I'm on a 4790k + 980Ti on Windows 7.
User avatar
Krazy
Thunder Beetle
52 | 0
I did like in the Screenshots, but with Diablo startet in Window Mode, within the Borderless Tool was not able to select the game. I pressed each hotkey multiple times that is defined in the General Settings of the tool.
User avatar
aerial
Onyx Knight
634 | 174
Great Popularity Badge
Has a thread with over 50.000 views
Great Love Badge
Earned over 100 cookies
Common Guide Badge
Created a complete character guide
you need make sure you highlight the window for borderless tool to work
it is issue of that program, to get it to work with any window not d2 related
Shendelzare
Imp
5 | 0
I'm getting huge black borders around my "borderless window" after I copied your settings to the letter. I'm playing on a 2560x1440 monitor.

Image
User avatar
aerial
Onyx Knight
634 | 174
Great Popularity Badge
Has a thread with over 50.000 views
Great Love Badge
Earned over 100 cookies
Common Guide Badge
Created a complete character guide
let it trigger on its own, don't force borderless app with hotkey
You can do it by clicking taskbar and clicking back d2 window, with few seconds of delay in between, it should activate on its own.
I'm not getting back bars, only sometimes when i first launch the game in menus.
Also make sure glide settings are the same, all windows extra, it might have something to do with it.