How to set up GLIDE WRAPPER + Borderless window (pimp your mxl)

Find a handful of guides and walkthroughs here!
Grasshopper
Azure Drake
161 | 3
Aerial, are you using Win 10? I can't get borderless tool to start in my Win 10 machine.
User avatar
aerial
Mahasattva
913 | 191
Great Popularity Badge
Has a thread with over 50.000 views
Great Love Badge
Earned over 100 cookies
Common Guide Badge
Created a complete character guide
Yes.
Check their manual, or just try different tool, there is plenty of apps that do same thing, remove window controls from windows, creating borderless window. App I'm recommending was just 1st from google search, that also happened to work for me without problems. But you can achieve same effect with many other tools.
Grasshopper
Azure Drake
161 | 3
aerial wrote:It can stretch if you uncheck "keep aspect ratio" in glide, but it looks like shit.


I have it unchecked and still it won't stretch. Are ther any other related settings?

EDIT: In case it helps others. I found one that worked, in Renderer section make sure to have 'Keep desktop composition' unchecked as well as the keep aspect ratio, then it stretches. :D

EDIT 2: Still not perfect. The game resest to 4:3 on entry to and exit from a game. I can still stretch it back but having to do it is a bit rubbish. I may try the Rememeber Window Position and see if it solves it (I could do this before Sigma so it should be do-able?).
Edited by Grasshopper 2 months.
thiccburritos
Fallen
1 | 0
Everytime I try to start the program using the 3dfx glide the program does not respond. I use an AMD radeon 7800 series
User avatar
Darthaghar
Abomination
141 | 10
aerial wrote:Just mess around with those settings, make it even smaller. If I input those, it doesn't cut off window like that.
I can for example set 1600x1200 window in glide, and then resize it to 800x600 with borderless tool, and it looks fine, just tiny window.


I am not sure why but when I change sizes with that borderless tool it gives me all kinds of weird issues...for example if i Set it to 800x600 it eats up like 60% of the window... (and no I dont have glide setting static size turned on... its turned off) so technically this shouldn't be the case but it is.... do i have to have a certain glide setting for this thing to work completely properly ? Also does anybody have another weird issue where at a certain spot near the health potion belt your mouse constantly gets stuck.. "in a mouse lock situation" but I dont have mouse lock inside the window enabled either so its weird that its glitching out every time my mouses passes by my Potion rows...
Playtime
Imp
4 | 2
jacksj1 wrote:So if I tick shader-gamma is there a way to adjust the brightness/gamma ? Client was too dark to see anything which was fixed by unticking this option.


As an aside thanks to Playtime for posting the following - setting static size to no fixed my black borders issue.

[spoiler]
Playtime wrote:For people complaining about black bars. Set static size to "no", continue with the rest of the guide.
May or may not cause other effects, such as an odd scaling making the "size" of the window behave odd in relation to your cursor and screen position.


This is hard to word. When using no static size, the window is the same size in the background, even though it's scaled to the res you set...
So say your window is 800*600, and you use the borderless tool to go to 1920*1440. It will zoom the 800*600 into that resolution. But the window itself is the same size.
Which makes your cursor feel extremely accelerated. Since it's move the same distance across the same window... But it APPEARS that it's moving further across your screen, since the window you visually see, is the larger one.

With no static size set, you can manually adjust the size of the window beforehand to the size you want. Which if you set a random anything to the res you want. Let's say a notepad window, using the borderless tool. You can drag your D2 window out to the same size (notepad is a reference size) then once at the correct size, press your hotkey on the borderless tool to set D2 to borderless.

This will now do the same thing I tried to explain above, but now the windows are the same size. Thus far removing that problem entirely.

It's an unusual fix, and a little annoying to do all the time. But it works well enough.


[/spoiler]



Heeey. I did a useful!

Now if only Gheed would stop holding out on me... I know he's got the good stuff hidden in the back.
Steeeliskt
Cultist
24 | 1
Common Supporter Badge
Donated 1 time
ty very much for this. It wasn't the exact fix for me, however it helped me tinker with the right settings to get it working. Had thought I figured out what you were saying when I was stretching out a notepad to match the size of the window, but ended up being able to drag while keeping correct aspect ratio with no weird mouse issues.

Can't believe how much better it looks now.

Playtime wrote:For people complaining about black bars. Set static size to "no", continue with the rest of the guide.
May or may not cause other effects, such as an odd scaling making the "size" of the window behave odd in relation to your cursor and screen position.


This is hard to word. When using no static size, the window is the same size in the background, even though it's scaled to the res you set...
So say your window is 800*600, and you use the borderless tool to go to 1920*1440. It will zoom the 800*600 into that resolution. But the window itself is the same size.
Which makes your cursor feel extremely accelerated. Since it's move the same distance across the same window... But it APPEARS that it's moving further across your screen, since the window you visually see, is the larger one.

With no static size set, you can manually adjust the size of the window beforehand to the size you want. Which if you set a random anything to the res you want. Let's say a notepad window, using the borderless tool. You can drag your D2 window out to the same size (notepad is a reference size) then once at the correct size, press your hotkey on the borderless tool to set D2 to borderless.

This will now do the same thing I tried to explain above, but now the windows are the same size. Thus far removing that problem entirely.

It's an unusual fix, and a little annoying to do all the time. But it works well enough.
User avatar
Speedpad
Prowler
17 | 0
Common Supporter Badge
Donated 1 time
Thanks for that topic, after a bit of tinkering, i got it to work with no black bar and no "dead mouse zone" to the right.

2560 x 1080 monitor, only change to glide settings were to put the static size to no (fix the "dead mouse zone"). Game settings on the borderless tool are 1400 x 1050 (i have my win bar @top), with an offset of x=1160 and y=30.

Still a problem left, but i think its glide related (been having it before this borderless shenanigans), if i put my cursor all the way to the bottom, it's teleported to the left, outside the D2 window (i could fix it witch capture mouse, but what's the point of windowed amaright ? ^^ ).
WizoGales
Fallen
1 | 0
Its a lot better to do this: Go to [Settings] at the launcher, On bottom right, click at[Application Data], open the [Launcher] folder and then edit the [settings.json] file to "windowed": true "nofixaspect": true. :lol:
tourian
Cultist
22 | 2
Just add this to your AHK, no need for external programs.

#IfWinActive ahk_class Diablo II

F10::
{
WinMove, Diablo II,, 1920, 0, 1920, 1200
}


The first two numbers are the X and Y positions, the second are the window size (X and Y) respectively.