Technical issue - Open GL

Need help installing the mod?
User avatar
Johnny Impak
Onyx Knight
640 | 23
Common Popularity Badge
Has a thread with over 10.000 views
Common Love Badge
Earned over 20 cookies
I've been having issues with running the game with the launcher since it was released.

Everytime I try to set it on 3DFX Glide mode, the game refuses to load and the following message pops up:

''Setpixelformat failed! OpenGL could not be activated. Please check your graphic card driver`

Which I did. It is a Radeon X1300/X1550 series. (I do not want to know how old this is.) Windows tells me graphic card drivers are up to date. Everything works fine in Direct3D and DirectDraw. I just want to play the game in full screen mode, and the only way I made it work was by bypassing the launcher entirely. Result is fugly, having tiles glitching out and the lightning flat out weird.
User avatar
Texalic
Grubber
326 | 21
Common Love Badge
Earned over 20 cookies
Common Supporter Badge
Donated 1 time
When you add " -3dfx" to the game shortcut do you still get the same message.

Well, it is possible it is because of GPU but that's sth that could be answered by whist only I think, maybe the requirements by the new engine are a little bit too much for your GPU. ;-|

Try with this, though there is a lot less settings available but maybe this could work for you.
https://www.zeus-software.com/downloads/nglide
Berkabus1
Balrog
135 | 8
I have a new computer , well its a laptop But still. From 2019. Not epic gear But well over budget. I cant play game either. Having 2-3 second delay all the time and i have been testning all the settings. Ive given up ! Waiting for new Patch and hope that its better then.. or sp But nah..
User avatar
Johnny Impak
Onyx Knight
640 | 23
Common Popularity Badge
Has a thread with over 10.000 views
Common Love Badge
Earned over 20 cookies
Talic wrote:When you add " -3dfx" to the game shortcut do you still get the same message.

Well, it is possible it is because of GPU but that's sth that could be answered by whist only I think, maybe the requirements by the new engine are a little bit too much for your GPU. ;-|

Try with this, though there is a lot less settings available but maybe this could work for you.
https://www.zeus-software.com/downloads/nglide


Will try this once I get the chance. Having a pc that can't run Diablo 2 in a glide wrapper in 2021 is genuinely making me laugh.
User avatar
ixvid_
Gravedigger
186 | 1
Common Popularity Badge
Has a thread with over 10.000 views
Berkabus1 wrote:I have a new computer , well its a laptop But still. From 2019. Not epic gear But well over budget. I cant play game either. Having 2-3 second delay all the time and i have been testning all the settings. Ive given up ! Waiting for new Patch and hope that its better then.. or sp But nah..


I had same issues, but with a pretty descent gaming laptop from 2016. (i5 3ghz, 8gb of ram, and gf gtx960 4gb) so imagine my frutsration, when I couldnt play 20yo game. All software was up to date, and no issue with other games. The solution was ... changing HDD to SDD. Since than zero problems, working flawlessly. Dunno if it help you, but for me it was like a miracle ;)
User avatar
budda
Rust Claw
84 | 2
Berkabus1 wrote:Having 2-3 second delay all the time and i have been testning all the settings. Ive given up ! Waiting for new Patch and hope that its better then.. or sp But nah..


- Your laptop can have 2 video cards: integrated video card and main. Some old games can have that issue, windows starts using integrated one (intel). Search via youtube : disabling integrated graphics on laptop. Step 2 disable hpet timer via bios (variant depent on windows version): also via youtube.
I have very old cpu: got in fauzt 75-64fps. Curently lags have trap rat packs (start from 1.7), daystar, and invisible curse with knockback of fazut bosses (alpha, beta etc).


Johnny Impak wrote:I've been having issues with running the game with the launcher since it was released...

- Well i dont play in D2 now and cant make new screens but u can make some test. Run 3d test (windows xp sp3).
Setup glide to min settings:
= if 32bit rendering checked - uncheck
= ive disabling vertical synchronization (in glide also in videocard settings). Less delay. Fps limit 30 or 100.
= uncheck keep dekstop resolution
= uncheck all GL_ settings like on screen below. Tell result.
► Show Spoiler

= i dont have radeon but try disable scaling mode. I know some bug from other old game when trying scaling game into not supported resolution creates crush
► Show Spoiler
vidar
Skeleton
2 | 0
Common Supporter Badge
Donated 1 time
Common Patron Badge
Patreon Contributor
budda wrote:
Berkabus1 wrote:Having 2-3 second delay all the time and i have been testning all the settings. Ive given up ! Waiting for new Patch and hope that its better then.. or sp But nah..


- Your laptop can have 2 video cards: integrated video card and main. Some old games can have that issue, windows starts using integrated one (intel). Search via youtube : disabling integrated graphics on laptop. Step 2 disable hpet timer via bios (variant depent on windows version): also via youtube.
I have very old cpu: got in fauzt 75-64fps. Curently lags have trap rat packs (start from 1.7), daystar, and invisible curse with knockback of fazut bosses (alpha, beta etc).


Johnny Impak wrote:I've been having issues with running the game with the launcher since it was released...

- Well i dont play in D2 now and cant make new screens but u can make some test. Run 3d test (windows xp sp3).
Setup glide to min settings:
= if 32bit rendering checked - uncheck
= ive disabling vertical synchronization (in glide also in videocard settings). Less delay. Fps limit 30 or 100.
= uncheck keep dekstop resolution
= uncheck all GL_ settings like on screen below. Tell result.
► Show Spoiler

= i dont have radeon but try disable scaling mode. I know some bug from other old game when trying scaling game into not supported resolution creates crush
► Show Spoiler


Thank you so much for this! I've been looking for a solution to the same problem with 2-3 sec lag, and this worked perfectly
User avatar
Johnny Impak
Onyx Knight
640 | 23
Common Popularity Badge
Has a thread with over 10.000 views
Common Love Badge
Earned over 20 cookies
None of the above worked for me. Can't even put the program to Windows XP compatibility. Oldest OS is Vista. But the game.exe shortcut doesn't work if the launcher is set on 3DFX. I set it back to Direct3D and the shortcut works.

So this means to me that they are somehow connected. Perhaps messing in the Glide wrapper could fix the strange colors I get. Although doing this I feel like Homer Simpson trying to stop a nuclear meltdown. I'm not very good at this haha.

About NGlide, I can probably download it and install it, but then will it appear magically in the graphic options alongside the 3 others ? If not I will probably need a hand to set it properly.
User avatar
Texalic
Grubber
326 | 21
Common Love Badge
Earned over 20 cookies
Common Supporter Badge
Donated 1 time
► Show Spoiler

EDIT:

Anyway, in d2vidtest keep the glide option checked, move glide files somewhere, just move them outside the game folder, install nglide and start the game, there is no need to change game exe shortcut properties, no need for -3dfx.

If you see 3dfx logo glide should be running, and glide config file will be here: C:\Windows\System32\nglide_config.exe

Now play with options if necessary, you will see once you start the game how does it work.
User avatar
Johnny Impak
Onyx Knight
640 | 23
Common Popularity Badge
Has a thread with over 10.000 views
Common Love Badge
Earned over 20 cookies
Will try that when I get the time. A three weeks old baby is actually keeping me busy. I will reply on this topic once done.

Thanks for trying to help.