Launcher issue - MXL deleted itself?

Need help installing the mod?
User avatar
Frytas
Djinn
532 | 79
Common Love Badge
Earned over 20 cookies
Hi, not sure if this is the right place to post it, sorry...

I played some MXL yesterday, had no issues at all. Today I started the launcher, hit Play and nothing happened, so I did it again, and then one more time, at which point the launcher told me only 2 instances of Diablo 2 are allowed.

I checked the processes (tasklist | find /i "diablo" and tasklist | find /i "game.exe"), but nothing was there. So I went into the game folder(D:\Gry\Diablo II) to see what's up. The game.exe wouldn't launch from there(error), but I thought that's ok, cause MXL creates it's own folder and files anyway. I looked into the Median XL folder and it turned out to be completely empty. The launcher doesn't detect it, it doesn't try to redownload the files, I'm completely at a loss as to what happened. Antivirus didn't remove any files.

Any ideas what to do? Since it doesn't offer me an option to download the mod(the button in the launcher still says "Play"), I'm kinda stuck.

edit:
I uninstalled mxl through the launcher("uninstall the mod" option), and it still only offered me the option to hit "Play" - at which point regular D2LoD launched.
So I uninstalled the launcher altogether, installed again, still "Play" is the only option and I'm back to the original situation.

edit2:
Reinstalled both D2+LoD and the launcher. MXL started downloading, but after it finished -> back to the original problem.

I get this error when trying to launch the game through game.exe, not sure if that helps in any way(clicking on "Play" in the launcher provides no error messages)
Image

edit3:
As suddenly as it broke, it started working again today. Cause unknown, but I can play, so thread can be closed if a mod sees this